Technology Requirements


Missouri Baptist University uses myMBULearn hosted by Canvas by Instructure for its online courses. The following hardware, software and computer settings are the minimum specifications to work with the application.  myMBULearn and its hosting infrastructure of Canvas by Instructure are designed for maximum compatibility and minimal requirements.

: Windows XP SP3 and newer; Mac OSX 10.6 and newer; Linux – chromeOS
Use a computer 5 years old or newer when possible; 1GB of RAM; 2GHz processor
Internet Speed: Minimum of 512 kbps
Mobile OS Native App Support: iOS 7 and newer; Android 2.3 and newer
Screen Size: myMBULearn is best viewed at a minimum of 1024×600, which is the average size of a notebook computer. If you want to view myMBULearn on a device with a smaller screen, we recommend using the Canvas mobile app.
Screen Readers: Macintosh: VoiceOver (latest version for Safari); PC: JAWS (latest version for Internet Explorer 10 &11); PC: NVDA (latest version for Firefox); There is no screen reader support for myMBULearn in Chrome.

myMBULearn supports the last two versions of every browser release. We highly recommend updating to the newest version of whatever browser you are using as well as the most up-to-date Flash plug-in.

As of July 31, 2015, we support the most recent versions of Flash and popular web browsers:

  • Internet Explorer 10 and 11
  • Chrome 43 and 44
  • Safari 7 and 8
  • Firefox 38 and 39 (Extended Releases are not supported)
  • Flash 17 and 18 (for recording or viewing audio/video and uploading files)

Some supported browsers may still produce a banner stating Your browser does not meet the minimum requirements for myMBULearn. If you have upgraded your browser but you are still seeing the warning banner, try logging out of myMBULearn and deleting your browser cookies. Learn how to clear your cache on a Mac or a PC.

Required Components:

Flash is required in several places in myMBULearn: media recording/streaming and viewing as well as uploading files to a course or an assignment. Other than these features, Flash is not required to use most areas of myMBULearn. Please note that some browsers, such as Firefox, may no longer support Flash.

The Java plug-in is required for screen sharing in Conferences. Please note that some browsers do not support Java. Otherwise, there are no other browser plug-ins used by myMBULearn.

Updating your Browser:

Visit Canvas’s website for clear instructions on how to update your browser or for instructions on how to modify your browser’s privacy settings.