Technology Requirements

Technology RequirementsIMG_0419

Missouri Baptist University uses Blackboard Learn 9.1 for its online courses. The following hardware and software are the minimum specifications to work with the application. Please pay close attention to the minimum requirements and the supported operating system and web browser configurations below. If your computer does not conform to these specifications, you can expect to have problems accessing or utilizing features in Blackboard, even if it has worked in the past.

Platform
: Windows XP, Vista, Windows 7 or Windows 8; MacOS X 
Software
: Microsoft Office (recommended), Adobe Reader and Adobe Flash Player (required for some content)
Hardware:
 A modern processor (1GHz Pentium III/Athlon or newer, or Mac G4/Intel or newer), 256MB of RAM, 512MB – 1 GB+ recommended; 5GB of free disk space
Browser:

For Windows:

  • Firefox 17 or later (recommended), or Internet Explorer 10
  • Internet Explorer 7 and below are NOT SUPPORTED

For Mac:

  • Firefox 17 or later (recommended), Google Chrome 26, or Safari 5.1 or later

You MUST also have the latest version of Java from Sun Microsystems (Windows users especially).

Helpful Links: You can download the required software for free at the following sites:

Modem: 56K (Cable or DSL strongly recommended)
Note for AOL Users: The AOL browser is not compatible with Blackboard. This is a known issue with AOL’s software that affects all AOL users who try to access Blackboard, thus it is completely outside of our control. If you use AOL for your Internet service, follow these steps to access Blackboard:

  • Log into AOL as you normally do.
  • Minimize the AOL browser (you will remain connected to the Internet)
  • Launch Internet Explorer 10 or later (not AOL) directly from the Start Menu.
  • Using Internet Explorer (not AOL), log into Blackboard at http://blackboard.mobap.edu.

Supported Operating Systems and Web Browsers for Blackboard Learn 9.1:
Microsoft® Windows® Operating System

Internet Explorer® 10 Internet Explorer 9 Internet Explorer 8 Firefox 17 Firefox 20 Google Chrome 26
Windows® XP (32-bit) Unsupported by Microsoft Unsupported by Microsoft Compatible Certified Compatible Compatible
Windows Vista® (32-bit) Unsupported by Microsoft Certified Compatible Certified Certified Compatible
Windows Vista (64-bit) Unsupported by Microsoft Compatible Compatible Certified Compatible Compatible
Windows 7 (32-bit) Compatible Certified Compatible Certified Certified Certified
Windows 7 (64-bit) Certified Certified Compatible Certified Certified Certified
Windows 8 (32-bit) Compatible Unsupported by Microsoft Unsupported by Microsoft Certified Certified Certified
Windows 8 (64-bit) Certified Unsupported by Microsoft Unsupported by Microsoft Certified Certified Certified

Apple® Mac OS® Operating System

Safari® 6.0.3 Safari 6.0.1 Safari 5.1 Safari 5.0 Safari 4.0 Firefox 17 Firefox 20 Google Chrome 26
Mac OSX 10.6 Unsupported by Apple Unsupported by Apple Certified Certified Compatible Certified Certified Certified
Mac OSX 10.7 Certified Certified (10.7.5) Certified Unsupported by Apple Unsupported by Apple Certified Certified Certified
Mac OSX 10.8 Certified (10.8.3) Certified (10.8.2) Certified Unsupported by Apple Unsupported by Apple Certified Certified Certified

Sun Java™ Runtime Environment (JRE) 7 is the only supported version of Java for Windows users. You can download it here. All users should visit this site to make sure that they have the latest version of Java for their computer.

Other Important Notes:

  • Internet Explorer 7 and below are not supported.
  • Firefox 1.x, 2.0, 3.0, 3.5, and 3.6 are not supported.
  • Safari 2.0, 3.x (or any version on Windows) are no longer supported.
  • On Apple Mac OSX, Google’s Chrome browser does not support JRE version 7 and therefore JRE version 6 should be used.

In the above tables, the following designations may be used:

  • Certified: Fully tested and supported
  • Compatible: Partially tested but should function properly
  • Unsupported: Either impossible or not tested